Skip to content
Htkyama Blog

Netlifyで使用するNode.jsのバージョンを指定する

Netlify, Node.js1 min read

NetlifyでGatsby.jsのbuildをした際に、Node.jsのバージョンが古くてエラーになったために修正方法を確認。

基本的には、以下参照

  • Manage build dependencies | Netlify Docs

対処としては

  • 環境変数NODE_VERSIONに設定
  • リポジトリのベースディレクトリに、.nvmrcファイル、または.node-versionファイルを置く

ことで、Netlifyでbuildする際のNode.jsのバージョンが指定できる。

Netlifyは、nvm-sh/nvm (Node Version Manager)を使って、使用するバージョンのNode.jsを読み込んでいる。

.nvmrcファイルは以下で作成可能。

$ node -v > .nvmrc

あとは、.nvmrcファイルをリポジトリにpushすることで完了。

無事、buildできました。

© 2020 All rights reserved.
RSS